Microsoft Wants Reddit Feedback

By | September 17, 2010 | 9 Comments


Microsoft Wants Reddit FeedbackIt looks like Microsoft continues its advertising campaign. This time, company asked Reddit users for the Internet Explorer 9 feedback.

If you have Reddit account already and want to provide some constructive criticism, head over to the following page and share your IE9 experience.

The installation took way too much time for a browser.
I didn’t like the fact a complete reboot is needed to use IE
That blank space over the tabs is useless.
Search field and tabs should not be on the same row.

Via: Neowin
Source: Reddit


About (Author Profile)


Vygantas is a former web designer whose projects are used by companies such as AMD, NVIDIA and departed Westood Studios. Being passionate about software, Vygantas began his journalism career back in 2007 when he founded FavBrowser.com. Having said that, he is also an adrenaline junkie who enjoys good books, fitness activities and Forex trading.

Comments (9)

Trackback URL | Comments RSS Feed

  1. bert says:

    The installation took way too much time for a browser.
    I didn’t like the fact a complete reboot is needed to use IE
    That blank space over the tabs is useless.
    Search field and tabs should not be on the same row.

    captain obvious to the rescue.

    • nobody says:

      two first points were a deal breaker for me
       
      i persisted and installed this damn thing, but i CANNOT see any non-tech relative of myself going around the net downloading dependancies for this stupid thing when each and every other browser installs from ONE file and does NOT require reboot/install addons etc..

  2. bingo007 says:

    and mine didnt install.it just failed during update.is it due to ie8 still installed in my pc or due to my OS being non-genuine?dunno what to do.

  3. monty says:

    WTF beta install over stable version without asking.

  4. RamaSubbu SK says:

    I have Win7 x64(Original Activated), it installs fine with out any problem. So far it is working fine for me.

Leave a Reply