Internet Explorer 8 New Tab Page Opens Slowly?

By | July 20, 2009 | 2 Comments

If you are annoyed by “Connecting…” messages when opening new tab in Internet Explorer, then continue reading because we have a solution to fix this.

One of the reasons on why this could happen is installed add-ons. Fortunately, IE team has provided a tool which will tell you how much certain extension can slow down new tab page load.

Just head over to Tools > Manage Add-ons and you should see something similar to this:
Internet Explorer 8 New Tab Page Opens Slowly?

As from the information in the right column, you can now optimize your load time by disabling one or few add-ons, unless you want to sacrifice functionality over performance.

Picture source: IE Blog

[digg-reddit-me]


About (Author Profile)


Vygantas is a former web designer whose projects are used by companies such as AMD, NVIDIA and departed Westood Studios. Being passionate about software, Vygantas began his journalism career back in 2007 when he founded FavBrowser.com. Having said that, he is also an adrenaline junkie who enjoys good books, fitness activities and Forex trading.

  • Andrew

    Would better sound like “View and manage your Internet Explorer malware”

  • Feran

    Hi, this is Feran with the IE Outreach Team. Great article and good advice.

    For more IE tips, tricks, tweaks and just other helpful information and advice check out the Internet Explorer Facebook Page: http://www.facebook.com/internetexplorer

    Thanks!